Table of Contents

0.9.1 Release Notes

Released: 2013-09-10

This is a minor release in the 0.9 branch to fix a handful of issues.

Note: If you are upgrading from 0.8.x or earlier, please read the 0.9.0 upgrade notes!

A summary of changes in this release:

  • Config: Fix the workaround for LuaSec 0.4.x to apply the ssl 'ciphers' option correctly
  • Config: Ability to specify the ssl 'dhparam' option simply as a path to a file, instead of a callback function
  • Windows: Fix s2s issues
  • Windows: Fix the ability to specify absolute paths to SSL certificates in the config
  • Build: Fix compilation issue on non-Linux systems that have glibc (such as Debian GNU/kFreeBSD)
  • API: Fix to our set library, that caused the :include() and :exclude() methods to behave incorrectly

Download

For packages, please see our download page.

Source

You can grab a tarball of prosody-0.9.1.tar.gz (OpenPGP signed), or grab the latest 0.9 source from Mercurial with:

hg clone https://hg.prosody.im/0.9 prosody-0.9

More information on dealing with Prosody's source can be found at these links:

 
doc/release/0.9.1.txt · Last modified: 2013/09/29 00:28 by Matthew Wild