#992 DNS requests don't get answers

Reporter pep.
Owner Nobody
Created
Updated
Stars ★ (1)  
Tags
  • Status-New
  • Priority-Medium
  • Type-Defect
  1. pep. on

    What steps will reproduce the problem? 1. ??? 2. `/cycle` a channel What is the expected output? Parts and joins the channel. What do you see instead? "movim@conference.movim.eu/pep.: cancel: Server-to-server connection failed: DNS resolution failed" movim is not the only affected MUC. What version of the product are you using? On what operating system? Using Archlinux aur/prosody-hg (trunk, b69b40a828fd) # Lua module versions lfs: LuaFileSystem 1.6.3 lxp: LuaExpat 1.3.0 socket: LuaSocket 3.0-rc1 ssl: 0.6 Please provide any additional information below. I can also provide (oob) pcap and strace (while attempting the dns resolution), and also full debug logs since prosody started, if this can be helpful. It works when using `dig` manually. `dig +short @108.61.10.10 conference.movim.eu` (A and AAAA) The pcap file shows that requests initiated by prosody don't get any answer (???) while the dig requests do. ``` Sep 17 18:46:43 Anderith prosody[411]: c2s12b6bb0: Received[c2s]: <presence xml:lang='en' type='unavailable' to='movim@conference.movim.eu/pep.'> Sep 17 18:46:43 Anderith prosody[411]: stanzarouter: Routing to remote... Sep 17 18:46:43 Anderith prosody[411]: mod_s2s: opening a new outgoing connection for this stanza Sep 17 18:46:43 Anderith prosody[411]: mod_s2s: stanza [presence] queued until connection complete Sep 17 18:46:43 Anderith prosody[411]: mod_s2s: First attempt to connect to conference.movim.eu, starting with SRV lookup... Sep 17 18:46:43 Anderith prosody[411]: adns: Records for _xmpp-server._tcp.conference.movim.eu. not in cache, sending query (thread: 0x1e317e0)... Sep 17 18:46:43 Anderith prosody[411]: adns: Sending DNS query to 108.61.10.10 Sep 17 18:46:43 Anderith prosody[411]: c2s12b6bb0: Received[c2s]: <presence xml:lang='en' to='movim@conference.movim.eu/pep.'> Sep 17 18:46:43 Anderith prosody[411]: stanzarouter: Routing to remote... Sep 17 18:46:43 Anderith prosody[411]: s2sout1861f10: trying to send over unauthed s2sout to conference.movim.eu Sep 17 18:46:43 Anderith prosody[411]: s2sout1861f10: stanza [presence] queued Sep 17 18:46:58 Anderith prosody[411]: adns: Reply for _xmpp-server._tcp.conference.movim.eu. (thread: 0x1e317e0) Sep 17 18:46:58 Anderith prosody[411]: mod_s2s: conference.movim.eu has no SRV records, falling back to A/AAAA Sep 17 18:46:58 Anderith prosody[411]: adns: Records for conference.movim.eu not in cache, sending query (thread: 0xd6fa70)... Sep 17 18:46:58 Anderith prosody[411]: adns: Sending DNS query to 108.61.10.10 Sep 17 18:46:58 Anderith prosody[411]: adns: Records for conference.movim.eu not in cache, sending query (thread: 0x1955940)... Sep 17 18:46:58 Anderith prosody[411]: adns: Sending DNS query to 108.61.10.10 Sep 17 18:47:13 Anderith prosody[411]: adns: Reply for conference.movim.eu (thread: 0xd6fa70) Sep 17 18:47:13 Anderith prosody[411]: adns: Reply for conference.movim.eu (thread: 0x1955940) Sep 17 18:47:13 Anderith prosody[411]: mod_s2s: DNS lookup failed to get a response for conference.movim.eu Sep 17 18:47:13 Anderith prosody[411]: mod_s2s: No other records to try for conference.movim.eu - destroying Sep 17 18:47:13 Anderith prosody[411]: s2sout1861f10: Destroying outgoing session bouah.net->conference.movim.eu: DNS resolution failed Sep 17 18:47:13 Anderith prosody[411]: stanzarouter: Received[s2sin]: <presence type='error' to='pep@bouah.net/a37dbf41-c442-4420-b29c-247be9f1ba35' from='movim@conference.movim.eu/pep.'> Sep 17 18:47:13 Anderith prosody[411]: stanzarouter: Received[s2sin]: <presence type='error' to='pep@bouah.net/a37dbf41-c442-4420-b29c-247be9f1ba35' from='movim@conference.movim.eu/pep.'> ``` I have tried clearing the dns cache via the admin console, and I can verify it's empty, but then I would expect this to happen to many more MUCs and it doesn't. Also I haven't been able to change my dns resolver, see #991[0]. Maybe dns cache is related as well (if there's an issue). I am going to restart my server now, hoping that fixes the issue. [0]: https://prosody.im/issues/issue/991

New comment