#747 LuaDBI no longer available in FreeBSD ports

Reporter Michael
Owner MattJ
Created
Updated
Stars ★ (1)  
Tags
  • Status-New
  • Priority-Medium
  • Type-Defect
  1. Michael on

    LuaDBI was hosted on Google Code, which currently is in read-only mode and will close down by the end of the year. Because there is no alternate project repository for LuaDBI, the LuaDBI port on FreeBSD has been marked broken a week ago ( http://www.freshports.org/databases/luadbi/ ), thus LuaDBI cannot be installed on FreeBSD at the moment, which means Prosody's mod_storage_sql does not work. There seems to be no new website for LuaDBI, otherwise I would have filed a bug against FreeBSD. If you guys still think this would be better, I will happily go for it. What version of the product are you using? On what operating system? Prosody 9.10 on FreeBSD 10.1, but should affect all FreeBSD versions.

  2. MattJ on

    Hi Michael! The LuaDBI repo was migrated to here: https://github.com/mwild1/luadbi If you could inform the package maintainers, that would be great.

    Changes
    • owner MattJ
  3. Michael on

    Thanks a lot for the quick reply. The FreeBSD maintainers have been informed via the following bug report: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212884

  4. Michael on

    We have unbroken the built on FreeBSD by copying the files from Google Code, therefore this bug can be closed (see FreeBSD bug linked above). However, to facilitate future versions, it would be great if the tags could be re-added in the GitHub repo (as documented in https://github.com/mwild1/luadbi/issues/36 ).

New comment