#550 mod_mam_archive uses sql.lib.lua which does not exist anymore

Reporter Jan Grewe
Owner Nobody
Created
Updated
Stars ★ (1)  
Tags
  • Status-New
  • Priority-Medium
  • Type-Defect
  1. Jan Grewe on

    I'm using mod_mam_archive with the prosody-0.10 Ubuntu package and got this error: Sep 29 21:08:34 c2scb2d90 error Traceback[c2s]: /usr/lib/prosody/core/moduleapi.lua:142: Failed to load plugin library 'sql', error: /usr/lib/prosody/modules/sql.lib.lua: No such file or directory stack traceback: [C]: in function 'error' /usr/lib/prosody/core/moduleapi.lua:142: in function 'require' ...usr/lib/prosody/external_modules/mod_mam_archive.lua:137: in function 'get_db' ...usr/lib/prosody/external_modules/mod_mam_archive.lua:189: in function '?' /usr/lib/prosody/util/events.lua:73: in function </usr/lib/prosody/util/events.lua:69> (tail call): ? (tail call): ? /usr/lib/prosody/modules/mod_iq.lua:54: in function '?' /usr/lib/prosody/util/events.lua:73: in function </usr/lib/prosody/util/events.lua:69> (tail call): ? /usr/lib/prosody/core/stanza_router.lua:188: in function 'core_post_stanza' /usr/lib/prosody/core/stanza_router.lua:135: in function 'core_process_stanza' /usr/lib/prosody/modules/mod_c2s.lua:244: in function 'func' /usr/lib/prosody/util/async.lua:88: in function </usr/lib/prosody/util/async.lua:86> I found the file on the intarwebs (https://apt-browse.org/browse/ubuntu/trusty/universe/amd64/prosody/0.9.1-1/file/usr/lib/prosody/modules/sql.lib.lua) and it seems to work with it now - maybe that could be included in the 0.10 package, too?

  2. Zash on

    This file was removed because it was no longer used. mod_mam_archive should not use it.

  3. Zash on

    Changes
    • title /usr/lib/prosody/modules/sql.lib.lua: No such file or directory mod_mam_archive uses sql.lib.lua which does not exist anymore

New comment