#236 moving contacts from mod_groups managed groups works unexpected

Reporter chaase42
Owner MattJ
Created
Updated
Stars ★ (1)  
Tags
  • Priority-Medium
  • Type-Defect
  • Status-Started
  1. chaase42 on

    *What steps will reproduce the problem?* 1. Configure mod_groups as usual 2. Move a mod_groups-contact into another folder 3. Reconnect 4. Move another mod_groups-contact into the folder 5. Reconnect *What is the expected output? What do you see instead?* I expect both moved contacts are in the target group. Instead the moved contacts are removed after reconnect and changing roster file (in this order). *What version of the product are you using? On what operating system?* 0.8.0-1 Debian package on Squeeze *Please provide any additional information below.* The attached patch does not set the persist-flag, if the contact is not new. So new contacts (from the sight of mod_groups) are not persistent and the others are not touched.

    Attachments
  2. MattJ on

    Much thanks, I'll commit this to 0.8. To whom should I attribute the commit? Either a nickname or a full name + email (e.g. as seen at http://hg.prosody.im/trunk/rev/36ac38fd9cbd ) will do.

    Changes
    • owner MattJ
    • tags Status-Accepted
  3. chaase42 on

    I am reachable as "Christian Haase <c.haaseXifu.com>" with replaced X of course :)

  4. MattJ on

    Fix shall be in 0.8.2, thanks!

    Changes
    • tags Status-Fixed
  5. MattJ on

    Spoke too soon :) I gave it a last minute review and I think we can actually fix this a bit better. However I'm not going to change it and commit it to 0.8 just before a release. I'll post a patch here shortly (remind me if I forget) which we can get into trunk.

    Changes
    • tags Status-Started

New comment