#839 offline storage not working

Reporter Christoph
Owner MattJ
Stars ★★ (2)  
  • Priority-Medium
  • Type-Defect
  • Status-Fixed
  1. Christoph on

    messages don´t deliver, mam isn´t working log output: datamanager debug Assuming empty offline storage ('cannot open /var/lib/prosody/xxx/offline/xxx.list: No such file or directory') for user: xxx 1nightly351-1~jessie on Raspbian GNU/Linux 8 (jessie) mysql storage and mod_mam

  2. MattJ on

    Hi Christoph, thanks for the report. Unfortunately this log message isn't useful. It is perfectly normal and it appears when everything is working ok. You didn't say which branch of Prosody you are using (we have nightly builds for 0.9, 0.10 and trunk), but offline messages are working fine for us and others. Which messages don't deliver? What clients are you using? How can you reproduce this issue?

    • owner MattJ
  3. Christoph on

    Hej MattJ! Thanks for your quick respond! It worked for me too since months and I can´t remeber I changed something, except updates. I´m using 0.10. Messages don´t deliver if the user is offline, online messages working fine. I´m using Conversation, Pidgin and Gajim. On every client its the same.

  4. TheGrave on

    Same environment/config and same problem here. Clients are Conversations and Gajim in my case. Downgraded to build 280, same story. The only error I get is in prosodyctl about: general error The version of LuaExpat on your system does not support stanza size limits, which may leave servers on untrusted networks (e.g. the internet) vulnerable to denial-of-service attacks. You should upgrade to LuaExpat 1.3.0 or higher as soon as possible. See http://prosody.im/doc/depends#luaexpat for more information. But this is old and never caused an issue. I think problem has occurred somewhere around the beginning of this year. I downgraded mod_mam to versions more than 6 months old but still no joy. Output from console: module:list("mydomain.com") | mydomain.com: | auth_internal_hashed | c2s | carbons | cloud_notify | disco | http | http_files | http_upload | iq | message | offline | ping | presence | private | roster | saslauth | smacks | smacks_offline | storage_sql | tls | vcard | Result: nil No mam messages sent as far as I can see in Gajim's XML console. What would cause that - no MAM capability advertised? Please advise what info do we need to provide.

  5. TheGrave on

    I stand corrected. Downgraded mod_mam files were screwed up. When I rolled back correctly to revisions more than 2 months old all back to normal. I guess things screwed up after introduction of MAM version 0.5.

  6. Christoph on

    Thanks to TheGrave! Downgrade mod_mam did the trickfor me too.

  7. Zash on

    Seems it resolved itself then.

    • tags Status-Fixed

New comment