#1032 libevent unavailable on debian (jessie) when using lua 5.2

Reporter OgresAreLikeOnions
Owner Nobody
Created
Updated
Stars ★ (1)  
Tags
  • Status-New
  • Priority-Medium
  • Type-Defect
  1. OgresAreLikeOnions on

    Just for info before anyone waste time, too. Unfortunately Debian ships lua-event in version 5.1 only. I do not know, if you can force lua 5.2 to use the older library. Or the package maintainer must be involved. Consequently prosody (0.10.0) falls back to the operating system default connection handling. Package: lua-event Version: 0.4.3-1 Architecture: armhf Lua-Versions: 5.1 Depends: libc6 (>= 2.4), libevent-2.0-5 (>= 2.0.10-stable), lua-socket

  2. Zash on

    Have you reported this to Debian?

  3. OgresAreLikeOnions on

    No, I have not. Shall I file a bug report? I fetched the source package from the debian repo and compiled it against lua 5.2. The resulted shared object works fine. Prosody is using epoll, now. ------ If anyone wants to reproduce it, please take note that you will need to install lots of packages left behind afterwards. I recommend a (debian) bootstraped chroot environment. # (look for deb-src lines in /etc/apt/sources.list) # apt-get install dpkg-dev # apt-get source lua-event # apt-get build-dep lua-event # cd lua-event-0.4.3 # cp debian/lua5.1.dh-lua.conf debian/lua5.2.dh-lua.conf # dpkg-buildpackage -b The result is in the parent folder in "lua-event_0.4.3-1_armhf.deb". Replace "armhf" with your arch - "amd64" for example. Just install it (outside the chroot) with "dpkg -i".

New comment